Amazon DocumentDB Error: Unable to Connect to Database
Issue
Connection setup tests fail. The following errors appear:
Unable to connect to database. Unknown client failure.
Environment
Connector: Amazon DocumentDB
Resolution
To resolve this issue, do the following:
- In Fivetran, go to your Amazon DocumentDB connection page.
- Select the Setup tab.
- Click Edit connection.
- Update the Host and port field with the hostname and port of your primary node.
- Click Save and Test.
Cause
To connect your Amazon DocumentDB to Fivetran, we need to connect to your database's primary instance. For more information, see our Amazon DocumentDB prerequisites.
This issue occurs when you provide only a replica node hostname without listing the primary node hostname first in your connection configuration.