Existing Proxy Agent Is Unavailable During Connection Setup
Issue
While using the Connect via proxy agent method to set up a connection, an existing Proxy Agent doesn't appear in the Proxy agents drop-down.
Environment
Database connectors that support the Proxy Agent connection method. For more information, see the list of supported connectors.
Resolution
To resolve this issue, do the following:
- Ensure the Proxy Agent is running and configured correctly. For more information, see our Proxy Agent overview documentation.
- Verify that the Proxy Agent and the destination you have selected are in the same region.
- If they are in different regions, there are two options:
- Configure a new Proxy Agent in the destination's region.
- Choose a destination that matches the Proxy Agent's region.
Cause
This issue may occur when a Proxy Agent isn't running or is located in a different region than the destination associated with the connection.