Error: Reconnect: We Were Denied Access To Google Drive
Issue
The connector's initial sync fails. The following error appears:
Reconnect: We can’t connect to the source system for this connector for the following reason:We were denied access to Google Drive. Please check the accuracy of your credentials. Depending on the cause, you may need to correct your connector’s account credentials, update your connection method, or reauthorize Fivetran.
Environment
Connector: Google Drive
Resolution
There are two ways you can resolve this issue.
Ensure the folder or files aren't restricted
Ensure your folder or file doesn't contain a Restricted Access label. To review the labels associated with your folder or file, do the following:
- In Google Drive, go to the applicable folder.
- In the top right, click View details. For individual files, click the file name and then click View details.
- A panel appears on the right. Select the Details tab, then scroll to the Labels section.
If your folder or file contains the Restricted Access label, you must remove it or ask your workspace administrator to remove it.
Ensure Fivetran can download your file(s)
Ensure we can download your file(s) by doing the following:
- In Google Drive, go to the applicable folder.
- Click the applicable file.
- In the top right, click View details.
- A panel appears on the right. Select the Details tab.
- Click Manage access.
- In the pop-up window, click the gear icon.
- Ensure the Viewers and commenters can see the option to download, print, and copy checkbox is selected.
Cause
This issue occurs when your data is restricted, preventing us from opening a file and syncing its contents.