New or Updated Data Is Missing From the Destination
Issue
New or updated data is missing from the destination, even though it was added or updated before the latest sync.
Environment
- Connector: Google Drive
- Sync mode: Magic Folder Mode
Resolution
To resolve this issue, do the following:
- Check whether we support the file you want to sync. For more information, see our Google Drive sync limitations.
- In Fivetran, go to your Google Drive connection page and use the Sync History chart to find the date and time of the last successful (complete) sync.
- In Google Drive, check the file's last modified date and compare it to the last successful sync time.
- If the last modified date is earlier than the last successful sync, modify the file slightly and ensure the timestamp updates.
- Perform a re-sync or wait for the next scheduled sync.
If the last modified date is later than the last successful sync and the file is still missing, contact our support team.
Cause
We don't support the following file types:
- Links to files from the cloud folder
- Hyperlink values from a worksheet
- Worksheets with pivot tables
- Files uploaded through the Google Drive app
In addition, we use the last modified date to detect file changes. However, when you use IMPORTRANGE in Google Drive or update a Google Sheets file through Google Forms, the last modified date doesn't update.
As a result, this issue occurs when you try to sync an unsupported file or the file's last modified date wasn't updated before the latest sync.