Error: Fivetran Catalog Unable to Access the Bucket
Issue
While setting up a Managed Data Lake Service (MDLS) destination with Google Cloud Storage (GCS), the following error appears:
Fivetran Catalog unable to access the bucket. org.apache.iceberg.exceptions.ForbiddenException: 403 Forbidden. The error occurs while attempting to upload Iceberg metadata files under the fivetran/ directory in the bucket.
Environment
Destination: Google Cloud Storage (Managed Data Lake Service)
Resolution
To resolve this issue:
In the Google Cloud Console, check whether hierarchical namespace is enabled. For more information, see the Google Hierarchical namespace documentation.
If hierarchical namespace is enabled, create a new Google Cloud Storage bucket with hierarchical namespace disabled.
- Ensure the bucket name and prefix path don't contain special characters.
- Frant the
Storage Object Adminrole to the Fivetran service account. - For more information, see our documentation on creating Google Cloud Storage buckets.
Update your Fivetran destination configuration:
i. In Fivetran, go to your Managed Data Lake Service destination page:
ii. Click Edit connection.
iii. Enter your Google Cloud Storage Bucket name.
iv. Click Save & Test.
Cause
This issue occurs when hierarchical namespace is enabled. Hierarchical namespace is incompatible with the Fivetran Iceberg REST Catalog, which requires standard object storage behavior to write metadata files.