Connectors or Destinations Fail After Upgrading From a Free Trial to a Paid Plan
Issue
Connectors or destinations fail after an account is upgraded from a free trial to a Free, Starter, or Standard plan.
Environment
- All connectors and destinations
- Pricing plan: Free, Starter, or Standard
Resolution
To resolve this issue, do the following:
- In the Destinations page of your Fivetran dashboard, select the destination associated with your connector.
- Under the Connection Details section, make a note of the Data processing location, Cloud service provider, and Cloud region.
- See our IP Addresses documentation and safelist the applicable IP address for your provider, region, and location.
Cause
Accounts on a free trial can access all Fivetran features, including selecting from different cloud service providers and regions. However, when you upgrade to a Free, Starter, or Standard plan, your cloud service provider selection becomes limited to the Google Cloud Platform (GCP). Only our Enterprise or Business Critical plans offer the ability to choose a different cloud service provider. See our data residency documentation for more information.
As a result, when you use a cloud service provider other than GCP while on a free trial and then upgrade to a Free, Starter, or Standard plan, the IP addresses associated with your provider change. This issue may occur if your firewall isn't configured to block connections from GCP IP addresses.