SAML Error: Issuer Value Does Not Match
Issue
While logging in using SAML authentication or testing a SAML configuration, the following error appears:
Issuer value in the fivetran account settings does not match the value in the provided SAML assertion.
Environment
- Account settings
- SAML authentication
Resolution
To resolve this issue, do the following:
- In Fivetran, go to Account Settings > General.
- Under SAML Config, check that the Public certificate matches your SAML identity provider's public certificate and doesn't contain trailing labels such as
-----BEGIN CERTIFICATE-----
and-----END CERTIFICATE-----
. - Click Save.
Cause
This issue occurs when the public certificate you provide while configuring SAML login is incorrect or contains trailing labels. To learn more, see our SAML Config documentation.