Error: F_JD20F2: Cannot Open Backup Device
Issue
Capture jobs fail for a SQL Server source that uses third-party transaction log backups. The following error appears:
F_JD20F2: DBMS error [[Microsoft][ODBC Driver 17 for SQL Server][SQL Server]Cannot open backup device
Environment
- HVR 6
- Source: SQL Server
- Recovery model: Full
- Backup method: Third-party transaction log backups
Resolution
To resolve this issue, set the LOG TRUNCATER option to CAP_JOB_RETAIN in the HVR UI. For more information, see our SQL Server Log Truncater documentation.
When you use the CAP_JOB_RETAIN method, we retain transaction logs internally and control the truncation point until changes are captured, eliminating the need to read third-party transaction log backup files.
Cause
This issue occurs when you use the default CAP_JOB log truncation method on a SQL Server source that uses third-party transaction log backups.
When this happens, we attempt to read transaction log backup files that are managed by the third-party tool and can't open the backup device, resulting in the above error.