Error: Unable to Connect to Bucket
Issue
The setup test fails with the following error appears:
Unable to connect to bucket. Could not connect to your bucket. We encountered the following error: 403 Forbidden GET {"code" : 403, "errors" : [ { "domain" : "global, "message" : does not have storage.objects.list access to the Google Cloud Storage bucket. Permission storage.objects.list denied on resource (or it may not exist)." }
Environment
Connector: Google Play
Resolution
To resolve this issue, ensure the authorized user has storage.objects.list permission on the Google Cloud Storage bucket.
- Log in to your Google Play console.
- Click Download reports.
- Click Statistics.
- Locate and copy your cloud storage URI.
- Locate your Bucket ID in the URI. For example, if the URI is
gs://Test_bucket/reviews/, your Bucket ID isTest_bucket. - In the Google Cloud console, grant the authorized user shown in the error message the
storage.objects.listpermission on that Google Cloud Storage bucket. For more information, see the Google Cloud documentation on managing IAM policies on buckets.
The Google API may not immediately reflect permission changes. If the error persists, try again after some time.
You must have the Storage Admin role to update bucket access. For more information, see the Google Cloud Roles required to manage buckets documentation.
Cause
This issue occurs when the authorized user is missing the storage.objects.list permission on the Google Cloud Storage bucket.