Error: Unable to Connect to Bucket
Issue
The setup test fails with the following error appears:
Unable to connect to bucket. Could not connect to your bucket. We encountered the following error: 403 Forbidden GET {"code" : 403, "errors" : [ { "domain" : "global, "message" : does not have storage.objects.list access to the Google Cloud Storage bucket. Permission
storage.objects.list denied on resource (or it may not exist)." }
Environment
Connector: Google Play
Resolution
Ensure the authorized user has storage.objects.list
permission on the Google Cloud storage bucket.
To assign the appropriate permissions on the bucket, do the following.
- Log in to your Google Play console.
- Click Download reports.
- Click Statistics.
- Locate and copy your cloud storage URI.
- Locate your Bucket ID in the URI. For example, if the URI is
gs://Test_bucket/reviews/
, your Bucket ID isTest_bucket
. - Log in to Google Cloud Storage.
- Filter using your Bucket ID.
- Go to the Permissions tab.
- Click + Grant access.
- Enter the email ID of the authorized user mentioned in the error message..
- Grant an appropriate IAM role that includes the missing permission mentioned in the error message.
NOTE: Google's API may not immediately reflect permission changes. If the error persists, try again after some time.
Cause
This issue occurs when the user does not have the permissions necessary to access a Google Cloud Storage bucket.