Error: We Were Unable to Sync Data for the PAYOUT
, TRANSACTION
, and PAYOUT_REPORT
Tables
Issue
The connection fails. The following error appears:
We couldn't sync 1 out of the 1 primary endpoint(s). We were unable to sync data for the following tables: [PAYOUT, TRANSACTION, PAYOUT_REPORT]. Error details: {[URL: /settlements/v1/payouts]: Fivetran framework error: Something went wrong.}
Environment
Connector: Klarna
Resolution
To resolve this issue, follow the steps below:
In Klarna, configure your settlements report to use a comma as the delimiter. For more information, see Klarna's Customize settlements reports documentation.
In Fivetran, re-authorize your connection.
i. Go to your Klarna connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Click Re-Authorize Connection.
Cause
This issue occurs when your Klarna settlements report uses a semicolon instead of a comma as the delimiter. This prevents us from correctly parsing data into the PAYOUT
, TRANSACTION
, and PAYOUT_REPORT
tables.