LinkedIn Ad Analytics Error: Unable to Access Selected Accounts
Issue
While setting up a new connection, the following error appears:
Unable to access selected accounts. We found no accounts to sync for the current user. Make sure you have sufficient permissions and accounts available and selected to sync.
Environment
Connector: Linkedin Ad Analytics
Resolution
To resolve this issue, ensure the authorizing user has been added to the relevant LinkedIn ad account in Campaign Manager and assigned one of the following Campaign Manager user roles:
Billing adminAccount managerCampaign manager
LinkedIn Business Manager roles and Page admin roles are insufficient.
For more information on how to add users and edit permissions in Campaign Manager, see the following LinkedIn resources:
Cause
This issue occurs when the authorizing user hasn't been added to the relevant LinkedIn Ads account or lacks the permission required to access the relevant data.