Microsoft Advertising Error: Unable to Access Selected Accounts
Issue
Setup tests fail with the following error:
Unable to access selected accounts
Environment
Connector: Microsoft Advertising
Resolution
To resolve this issue, do the following:
Ensure your Microsoft Advertising credentials are active and valid, and you can access the relevant account.
Log out of your Microsoft Advertising account.
In an Incognito window, re-authorize the connection.
i. In Fivetran, go to your Microsoft Advertising connection page.
ii. Select the Settings tab.
iii. Click Edit connection.
iv. Click Re-Authorize Connection and ensure you provide the correct credentials.
v. Click Save & Test.
Google Sign-In identity mismatch
If your account email was originally registered using Google Sign-In, do the following:
- Remove your user/email access from the Microsoft Advertising admin portal.
- Re-add your user, ensuring you set up access as a Personal account without using Google Sign-In.
- Re-authorize the connection in Fivetran using the steps above.
Cause
This issue may occur due to one of the following reasons:
- The authorizing user's credentials are invalid or incorrect.
- The OAuth token associated with the connection has expired or been revoked, possibly due to a password reset.
- The account email was originally registered using Google Sign-In, causing an identity type mismatch when authenticating with a Microsoft account. For more information, see Microsoft Error 126 IdentityTypeMismatch documentation.