Error: Unable To Connect to API. HTTP 400 Bad Request
Issue
While attempting to connect using a valid Salesforce email address and password, the following error appears:
Unable to connect to API. HTTP 400 Bad Request
Environment
Connector: Pardot
Resolution
To resolve this issue, enter your Salesforce username in the SSO account username field instead of the email address associated with your account.
Your Salesforce username does not need to match the email address associated with your Fivetran account.
Cause
This issue occurs when you enter your Salesforce email address in the SSO account username field and that email address is associated with multiple Salesforce organizations.
Salesforce usernames follow an email address format but must be unique for each organization. As a result, your Salesforce username may differ from the email address associated with your account. For more information, see the Salesforce Usernames and Passwords documentation.