Data Extension Tables Are Missing From the Destination
Issue
The connection setup tests complete successfully, but data extension tables are missing from the destination.
Environment
Connector: Salesforce Marketing Cloud
Resolution
To resolve this issue, do the following:
In Salesforce Marketing Cloud, verify that the authenticating user has Read and Write permissions for the Data Extension tables.
Confirm that the user is assigned to a business unit. For more information, see the Salesforce Associate Users with Business Units documentation.
In Fivetran, confirm that you have provided valid SFTP credentials.
i. Go to your Salesforce Marketing Cloud connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Check that the Provide SFTP credentials toggle is set to ON.
v. Verify that the Host, Port, and User values match the credentials you created in SFMC. For more information, see our Create account in SFMC documentation.
vi. Click Save & Test.
Cause
This issue may occur for one or more of the following reasons:
- The authorizing user lacks the permission required to access data extension tables.
- The user isn't assigned to a business unit.
- The SFTP credentials are missing or invalid.