Child Class Records Are Missing From the Destination
Issue
When syncing ServiceNow tables that use class/parent hierarchy, such as CMDB_CI_SERVER, some child class records are missing from the destination. The sync completes without errors.
Environment
Connector: ServiceNow
Resolution
To resolve this issue, do the following:
- In Fivetran, set up a new ServiceNow connection.
- In the setup form, set the Include inherited columns toggle to OFF.
- Click Save & Test.
When the connection's initial sync completes, records from both parent and child classes appear your destination.
Cause
This issue occurs because of the ServiceNow class-table inheritance. Each record is stored once in its leaf, or child, table and inherits columns from its ancestor, or parent, tables. When you set the Include inherited columns toggle to ON, we sync records where sys_class_name matches the selected parent table and exclude records from child classes.
For example, if you select cmdb_ci_server CMDB_CI_SERVER as the parent table and set the Include inherited columns toggle to ON, we exclude rows where sys_class_name is not cmdb_ci_server.
For more information, see Updating data in ServiceNow.