Error: Unable to Connect to API
Issue
Connection setup tests fail. The following error appears
Unable to connect to API. HTTP 401 Unauthorized
Environment
Connector: Taboola
Resolution
To resolve this issue, do the following:
Contact your Taboola Account Manager or Taboola Support (support@taboola.com) to confirm your API access and request new API credentials (
client_id
andclient_secret
).Update your connection details.
i. In Fivetran, go to your Taboola connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Provide the new Client ID and Client Secret.
v. Click Save & Test.
Cause
If the connection's authorizing user is deactivated, changes roles, or loses API access, the API credentials become invalid, causing this error. In some cases, the Taboola API may also incorrectly reject valid credentials.