The Connection Setup Reflects the Wrong Connecting User Email
Issue
A new user authenticated the connection. However, on the connector page's Setup tab, the Connecting User Email field reflects the previous authenticating user's email address.
Environment
Connector: Zendesk Support
Resolution
To resolve this issue, wait until the next scheduled sync starts. You don't need to take any action.
Cause
When a new user authenticates the connection, the Connecting User Email field initially reflects the previous authenticating user's email address. We fetch and update this field with the new email address when we start the next scheduled sync.