Error: An Error Occurred While Either Issuing the Tokens or Accessing a Protected Resource
Issue
Setup tests fail. The following error appears:
We could not connect to Amazon Selling Partner because an error occurred while either issuing the tokens or accessing a protected resource.
Environment
Connector: Amazon Selling Partner
Resolution
To resolve this issue, do the following:
Ensure the authorizing user has Admin access to your Amazon Seller Central or Vendor Central account.
Re-authorize the connection.
i. In Fivetran, go to your Amazon Selling Partner connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Click Re-Authorize Connection. This action redirects you to Amazon's authorization page.
v. On Amazon's authorization page, sign in to your Amazon Seller Central or Vendor Central account.
vi. Click Allow to grant access to the Amazon application. This action redirects you back to the Edit connection page.
vii. Click Save & Test.
If the error reappears, re-authorize the connection using your browser's Incognito mode.
If the error persists, contact our support team.
Cause
This issue may occur due to either of the following reasons:
- Amazon experienced intermittent issues or downtime.
- Amazon invalidated your access token due to a password change or an update to your account settings.