Error: We Were Unable to Connect to SAP Qualtrics Server Using Your Credentials
Issue
Setup tests fail. The following error appears:
Uh oh! We were unable to connect to SAP Qualtrics server using your credentials. Error : HTTP 401 Unauthorized
Environment
Connector: Qualtrics
Resolution
To resolve this issue, do the following:
Confirm the account associated with your connection is active and you can log into the Qualtrics site.
Ensure the authorizing user has an Administrator role. For more information, see our Qualtrics Setup Guide.
In Qualtrics, make a note of your datacenter ID. For more information, see Qualtrics' Finding IDs documentation.
In Fivetran, ensure you have provided the correct datacenter ID, then re-authorize the connection.
i. Go to your Qualtrics connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Ensure Data Center field contains the datacenter ID you found in step 3.
v. Click Re-Authorize Connection.
vi. Click Save & Test.
If the issue persists, contact Qualtrics support for further assistance.
Cause
This issue may occur due to any of the following reasons:
- The API token used for authentication is invalid or has expired.
- The account associated with the connection is inactive or has been disabled.
- The datacenter ID provided in the connection setup form is invalid or incorrect.
- The authorizing user doesn't have the permissions required to set up the connection.